Bibliotecas de Conteúdos

Depois de algumas tentativas com bom resultado, mas ainda sem possibilitar o aprendizado de uma forma efetiva para diferentes perfis de alunos, conversando com vocês, chegamos ao novo formato do Office Resolve: Bibliotecas de Conteúdos!

As Bibliotecas são coleções de vídeos bem curtos, baseados em um exemplo prático, porém focado em um tema de aprendizagem específica.

Por exemplo: Um vídeo de 2 minutos explicando como usar a Formatação Condicional, do tipo “Regra de Realce das Células“, com sub tipo “É maior do que“, usando como exemplo uma lista de notas dos alunos de um treinamento.

Com esse vídeo, você consegue não só aprender um conceito (se ainda não tiver visto) mas também consultar sempre que precisar relembrar como fazer.

Como posso localizar os conteúdos em vídeo

Aprender com vídeos tem dois possíveis problemas: ou os vídeos são grande demais para serem consultados depois, ou a quantidade de vídeos fica tão grande que não é possível mais achar os vídeos específicos onde estão os conceitos procurados.

Pensando nisso, nossa biblioteca terá dois tipos de vídeos os de treinamento com média de 20 minutos, e os de consulta, com média de 3 a 5 minutos. Além de um índice completo para os vídeos de consulta, com os temas específicos abordados em cada vídeo, agrupados por categorias mais gerais para facilitar a localização.

Assim, seja a forma que você queira utilizar, poderá achar aquilo que precisa.

Isso é tudo?

Não! Ainda teremos exercícios e textos descritivos para facilitar o entendimento e as consultas rápidas.

Excel: como montar funções efetivas?

Vamos nesse pequeno post lembrar algumas coisas que podem ser a diferença entre funções “defeituosas” ou funções “poderosas”.

A primeira coisa que muitas pessoas esquecem é que as planilhas mudam. Devemos lembrar que muitas vezes o número de linhas e colunas da planilha inicial  (quando estamos montando a função) vai aumentar.

Como fazer funções que acompanham o aumento da planilha?

O Excel já tem uma série de mecanismos para refletir as alterações nas funções, mas a utilização do recurso de nomes para intervalos ajuda bastante. Veja o exemplo a seguir:

Em vez de “=SOMA(B2:C4)” você poderia fazer “=SOMA(meu_intervalo)”, aplicando o nome “meu_intervalo” ao intervalo B2:C4.

Claro que isso não garante a correção da planilha, mas quando houver alteração basta ajustar os nomes (se necessário) e não será preciso ajustar a função.

 Segundo erro que atrapalha muito a efetividade das funções é usar parâmetros fixos na função.

Sempre preferir usar endereços!

Usar endereço nada mais é que referenciar a célula ou intervalo com o valor do parâmetro. Exemplo:

Em vez de “=SOMASE(A2:A10;”contas”;B2:B10) use “=SOMASE (meu_rotulo; meu_criterio; meus_valores). Como assim? Estamos juntando a dica 1 e a dica 2. Nomeie os intervalos e coloque o nome “contas” em um intervalo também nomeado.

  • meu_rotulo: A2:A10
  • meu_criterio: D4 (apenas um exemplo)
  • meus_valores: B2:B10

Fazendo isso, suas funções ficaram bem mais robustas e a manutenção consumirá bem me nos tempo. Talvez no momento de criar a função você gaste um pouco mais de tempo, mas valerá muito a pena depois!